Update your security encryption to TLS1.2 by June 19

0 min read
openprovider blog about domains

tls1.2We are informing our customers about an important technical update. Transport Layer Security version 1.2 (TLS1.2) will become mandatory for communication from the 19th of June onwards. Because of this, will need to verify that your environment supports TLS1.2, and if necessary make appropriate updates.

Be aware that the information that follows is of a highly technical nature. Because of the nature of this information, we recommend that it is carefully reviewed by your web programmer or system administrator.

Openprovider is upgrading the protocols to the current industry standards in order to secure all external connections made to the following systems:

  • API: https://api.openprovider.eu.
  • RCP: https://cp.openprovider.eu.
  • EPP: https://epp.openprovider.eu.
  • https://*.registrar.eu.

Using older encryption protocols than TLS1.2 will lead to connectivity issues with our systems. Please verify that your environment supports TLS1.2 and, if necessary, update your systems.

This check is most important for customers using our API. Most browsers already support TLS1.2. You can check whether your browser already supports it here.

We understand that this technical information may be complicated. Do you need help with checking your systems or managing upgrades? Our support team is always happy to assist you. If you create a ticket for support, we will make sure to come back to you as soon as possible.

Subscribe to our newsletter

Looking for the best Domain Reseller Program?

OpenProvider offers you the best prices in the market and more. Register your .com domains for only $8.57 now!