Client Area Sign In

Openprovider Support

Contact our support department using the form on this page. For more information about the availability of our support team, please visit our Knowledge Base. Here, you can also find answers to many questions.




Update your security encryption to TLS1.2 by June 19

The information that follows is of a highly technical nature and should be reviewed by one of the following: web programmer/system administrator.

Openprovider is upgrading the protocols to the current industry standards in order to secure all external connections made to the following systems:

  • API: https://api.openprovider.eu
  • RCP: https://rcp.openprovider.eu
  • EPP: https://epp.openprovider.eu
  • https://*.registrar.eu

Transport Layer Security version 1.2 (TLS1.2) will become mandatory for communication from the 19th of June onwards. You will need to verify that your environment supports TLS1.2, and if necessary make appropriate updates.

Using older encryption protocols will lead to connectivity issues with our systems.

This check is most important for customers using our API. Most browsers already support TLS1.2. Check your browser here.

You must be logged in to post a comment.
Menu